Home > Gcc Error > Gcc Error Unrecognized Option '-kpic'

Gcc Error Unrecognized Option '-kpic'

asked 4 years ago viewed 1131 times active 4 years ago Related 2multiple unrecognized options in f773gcc: ignore unrecognized option0Header not found despite the use of the -I option1When I use Ivan. The author will not be held liable for any problems that result from the information provided here.

Copyright Leave a Comment Username (required) : Email (required) : Web Site : Comment : Search Search for: Categories AIX Debugging (1) AIX Package Management (2) Apache (29) Apple (27) Articles, Presentations his comment is here

If you don't want to go to the effort of install ld (and you probably shouldn't), you can usually get by by forcing perl to install the module. Join our community today! yes checking whether to enable maintainer-specific portions of Makefiles... Search this Thread 02-11-2008, 01:36 AM #1 adarshkmr LQ Newbie Registered: Feb 2008 Posts: 3 Rep: Compilation error : cc: unrecognized option `-KPIC' I am porting one application form https://www.prelude-siem.org/issues/288

No output written to blib/arch/auto +/DBI/DBI.so *** Error code 1 make: Fatal error: Command failed for target `blib/arch/auto/DBI/DBI.s +o' bash-2.03$ [download] ... The time now is 10:51 PM. You can replace -Kpic with -fPIC in php's Makefile.

bash-2.03$ perl Makefile.PL *** Note: The optional PlRPC-modules (RPC::PlServer etc) are not installed. Why do some items survive time travelling in Majora's Mask? Replace custom functions, leave built in functions untouched? Compilation failed in require at (eval 294) line 3. - Any pointers on what the problem could be?

Justin on June 1st, 2009 Great blog. This program has absolutely no warranty. Thank you! 04 Apr 2011 16:49 UTC Dmitry Zayats wrote: very nice article and it's also valid for Solaris 10 SPARC.In my case there is one more option that gcc doesn't understandarch=v8I redid this python LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie Compilation error : cc: unrecognized option `-KPIC' User Name Remember Me?

See the README for Solaris-PerlGcc. If you want to use the DBD::Proxy driver and DBI::ProxyServer ... adarshkmr View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by adarshkmr 02-11-2008, 06:23 PM #2 Tinkster Moderator Registered: Apr 2002 Location: in I haven't looked into it myself yet, but it might be useful. -- mowgli [reply] Re: Install DBI on Solaris by steves (Curate) on Feb 21, 2003 at 10:07UTC Solaris is

However, while running, DBI is complaining with the following error: -- install_driver(Oracle) failed: Unable to get DBI state from DBI::_dbistate at 14d580. http://blog.zorinaq.com/opensolaris-how-to-build-cpan-perl-modules-with-gcc-instead-of-t/ Tmack on January 9th, 2008 You might also need to edit Config_heavy.pl (in the same dir as the Config.pm) to edit the flags and make CPAN.pm happy, since it is req'd I am running gcc 4.8.2 and gfortran and Python 2.6. matty on July 29, 2006 | Filed Under Perl 13 Comments Ivan R.

I know that the flags in the source files aren't supported by Sun's own compiler so I was using gcc and have already made sure that all cc are referring to this content Browse other questions tagged linux gcc makefile or ask your own question. If I have to, I will post my results here. version infmn is as follows /home/users/bldadm2/pvcs/ib/mcs/src/mcs/utils :CC --version CC: Warning: Option --version passed to ld, if ld is invoked, ignored otherwise GNU ld version 051128 20051128 Copyright 2005 Free Software Foundation,

This email and any files transmitted with it are confidential and proprietary to Algorithmics Incorporated and its affiliates ("Algorithmics"). Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search on July 30th, 2006 You should checkout perlgcc(1), which is specifically for dealing with the situation. http://meditationpc.com/gcc-error/gcc-error-unrecognized-option-qmaxmem-1.php Riccardo Murri on November 20th, 2008 Hi - thanks for this post, it contains the solution I've been googling after for a long time!

This program is free software; you may redistribute it under the terms of the GNU General Public License. Join them; it only takes a minute: Sign up cc: unrecognized option '-KPIC' up vote 1 down vote favorite I have the following in my makefile: CC = cc -g -KPIC more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Not the answer you're looking for?

I can't find the location in the source or setup.py file where this flag is passed to the compiler. If you'd like to contribute content, let us know. Re: Install DBI on Solaris by jepri (Parson) on Feb 21, 2003 at 02:20UTC Just from eyeballing it, it appears that perl still thinks you have CC (ugh). After reading it, I created a simple wrapper script that will invoke "gcc" and remove the offending options: https://twiki.cscs.ch/twiki/bin/viewfile/LCGTier2/PhoenixBlog20081120x1505?filename=perlcc I installed it as "/usr/bin/cc" and now "cpan -i Time::HiRes" works fine.

Remember to actaully *read* the REAME file! ... What cracks me is the line ... By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. check over here If you want to build a single module with gcc, you can edit the Makefile that was produced by ‘perl Makefile.PL', and remove the "-KPIC" and "-xO3 -xspace -xildoff" values from